function drush_module_disable

8.0.x environment_7.inc drush_module_disable($modules)
8.0.x environment_6.inc drush_module_disable($modules)
8.0.x environment.inc drush_module_disable($modules)
6.x environment_6.inc drush_module_disable($modules)
6.x environment.inc drush_module_disable($modules)
6.x environment_7.inc drush_module_disable($modules)
7.x environment_7.inc drush_module_disable($modules)
7.x environment_6.inc drush_module_disable($modules)
7.x environment.inc drush_module_disable($modules)
3.x environment_7.inc drush_module_disable($modules)
3.x environment_6.inc drush_module_disable($modules)
3.x environment_5.inc drush_module_disable($modules)
4.x environment_6.inc drush_module_disable($modules)
4.x environment_5.inc drush_module_disable($modules)
4.x environment.inc drush_module_disable($modules)
5.x environment_6.inc drush_module_disable($modules)
5.x environment.inc drush_module_disable($modules)
master environment_7.inc drush_module_disable($modules)
master environment.inc drush_module_disable($modules)

Disable a list of modules. It is assumed the list contains all dependents not already disabled.

Parameters

$modules: Array of module names

2 calls to drush_module_disable()
_drush_pm_disable in commands/core/drupal/pm_8.inc
Command callback. Drupal 8 does not support disabled modules.
_drush_pm_disable in commands/core/drupal/pm.inc
Command callback. Disable one or more extensions.

File

commands/core/drupal/environment.inc, line 214
Specific functions for a drupal 8+ environment. drush_include_engine() magically includes either this file or environment_X.inc depending on which version of drupal Drush is called from.

Code

function drush_module_disable($modules) {
  drush_set_error('DRUSH_MODULE_DISABLE', dt('Drupal 8 does not support disabling modules. Use pm-uninstall instead.'));
}