public function SqlVersion::valid_credentials

8.0.x SqlVersion.php public SqlVersion::valid_credentials($db_spec)
7.x SqlVersion.php public SqlVersion::valid_credentials($db_spec)
master SqlVersion.php public SqlVersion::valid_credentials($db_spec)
1 method overrides SqlVersion::valid_credentials()

File

lib/Drush/Sql/SqlVersion.php, line 28

Namespace

Drush\Sql

Class

SqlVersion

Code

public function valid_credentials($db_spec) {
  // Drupal >=7 requires PDO and Drush requires php 5.3 which ships with PDO
  // but it may be compiled with --disable-pdo.
  if (!class_exists('\PDO')) {
    drush_log(dt('PDO support is required.'), LogLevel::BOOTSTRAP);
    return FALSE;
  }
  return TRUE;
}